Mission Control Portal Sign up ( https://telnyx.com/sign-up ) intermittently working
Incident Report for Telnyx
Resolved
Thank you for your continued patience.

Our engineers have resolved the intermittent sign up to our Mission Control Portal. You should now have no difficulty when attempting to sign up via any of our sign up links.
Posted Jan 15, 2020 - 17:16 UTC
Identified
We've identified a case where some referral links, that lead to our sign up page, are resulting in an error, when attempting to sign up.

Users may come across some difficulty signing up with certain sign up links.

Our engineers are investigating as we speak and we hope to have the issue resolved shortly.

Should you wish to sign up, you can visit telnyx.com and click the sign up button on the top right.

Visiting the sign up link directly ( https://telnyx.com/sign-up ) may also result in an error, so the above method is preferred for now.
Posted Jan 15, 2020 - 16:27 UTC
This incident affected: Mission Control API (East Region, Central Region, West Region).