Unplanned Maintenance - Mobile Data Services (US Region)

Incident Report for Telnyx

Resolved

Duplicate incident - please disregard.
Posted Mar 30, 2026 - 04:59 UTC

Investigating

We are performing unplanned maintenance on mobile packet core infrastructure in the US region. This maintenance is expected to last approximately 10 minutes.

A small subset of mobile data customers may experience brief session interruptions during this window. Active data connections will be re-established automatically in most cases. Affected users may need to toggle airplane mode on for 10 seconds and then off to restore connectivity.

We will provide an update once the maintenance is complete.
Posted Mar 30, 2026 - 04:59 UTC
This incident affected: Programmable Wireless.