Telnyx Cloud Storage us-central-1 partial outage

Incident Report for Telnyx

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted May 07, 2026 - 22:56 UTC

Identified

Found the root cause and currently implementing a fix.
Posted May 07, 2026 - 19:10 UTC

Investigating

User operations on buckets and objects located in us-central-1 region might be inaccessible. We're currently investigating the issue, and will provide an update soon.
Posted May 07, 2026 - 17:36 UTC
This incident affected: Telnyx Storage.