10DLC Assignments Failing and Some Messages Failing with 40010

Incident Report for Telnyx

Identified

Our downstream partner has identified an issue syncing the latest 10DLC registration data on their platform. As a result, in addition to a subset of 10DLC assignments failing, a small subset of messages are failing with a 40010 (Unregistered 10DLC Message) error despite successful registration of the sender. Our downstream partner is implementing a fix.
Posted Feb 03, 2026 - 23:16 UTC

Update

We are noticing a slight increase in errors causing 10DLC phone number assignment failures related to our downstream partner. We are currently investigating with our partner.
Posted Feb 02, 2026 - 17:16 UTC

Investigating

We are currently investigating this issue.
Posted Feb 02, 2026 - 16:43 UTC