Cloud Storage Degradation in us-east-1

Incident Report for Telnyx

Postmortem

Root cause: internal deploy.

Short-term remediation:

  1. Roll-back of the deploy
  2. Hot fix application, testing, and re-deploy

Long-term remediation:

  1. Alert optimization and deployment monitoring.
Posted May 29, 2025 - 19:29 UTC

Resolved

This incident has been resolved.
Posted May 29, 2025 - 18:03 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 29, 2025 - 17:34 UTC

Update

Cloud Storage us-east-1 temporarily unavailable for bucket creation. We're actively investigating the issue.
Posted May 29, 2025 - 16:58 UTC

Investigating

We are currently investigating this issue.
Posted May 29, 2025 - 16:56 UTC
This incident affected: Telnyx Storage.