Issues with 911 calls to Mexico

Incident Report for Telnyx

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 16:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 25, 2025 - 18:21 UTC

Identified

General issues when attempting to connect to 911 emergency services in Mexico.
The issue has been identified.
Posted Jul 25, 2025 - 17:17 UTC
This incident affected: Outbound Calling Services (Outbound Calling Services - United States, Outbound Calling Services - Canada).