Mission Control Portal - Chat Provider Issues
Incident Report for Telnyx
Resolved
This incident has been resolved.
Posted May 30, 2024 - 14:44 UTC
Investigating
Our live chat service provider is currently experiencing issues causing increased error rates and high latencies, leading to increased agent response times.

They are investigating this issue, and we thank you for your patience.
Posted May 29, 2024 - 15:09 UTC