AT&T 10DLC MMS Duplicate Messages

Incident Report for Telnyx

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 05:27 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2025 - 17:54 UTC

Update

We are investigating reports of duplicate messages being sent towards AT&T destinations on MMS routes.

Telnyx sees no duplication of messages on our platform, we are escalating downstream with our partners to resolve this issue.

Our downstream partner continues to investigate the issue on their side. We will provide updates as we receive them.
Posted Dec 03, 2025 - 01:07 UTC

Investigating

We are investigating reports of duplicate messages being sent towards AT&T destinations on MMS routes.

Telnyx sees no duplication of messages on our platform, we are escalating downstream with our partners to resolve this issue.
Posted Dec 02, 2025 - 19:05 UTC
This incident affected: Programmable Messaging - Long Codes (NORAM).