10DLC T-Mobile MMS Delays
Incident Report for Telnyx
Resolved
This incident has been resolved.
Posted Oct 31, 2024 - 16:26 UTC
Investigating
We're seeing some elevated time to finalise messages over T-Mobile MMS routes.

We're working downstream to resolve this issue with T-Mobile.
Posted Oct 30, 2024 - 18:19 UTC
This incident affected: Programmable Messaging - Outbound (API V1, API V2) and Programmable Messaging - Long Codes (NORAM).