Data Connectivity Issues When Roaming via IMSI1

Incident Report for Telnyx

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 14:05 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 30, 2025 - 21:16 UTC

Identified

We have identified that the data connectivity issue is isolated to the Telus network in Canada when roaming via IMSI1.

Recommended Action:
Users are advised to manually switch their devices to an alternative available network, such as Bell, Rogers, or SaskTel, where data services are working as expected.
Posted May 30, 2025 - 19:54 UTC

Investigating

We are currently investigating this issue.
Posted May 30, 2025 - 16:25 UTC
This incident affected: Programmable Wireless.