10DLC T-Mobile MMS Delays
Incident Report for Telnyx
Resolved
This incident has been resolved.
Posted Oct 30, 2024 - 15:41 UTC
Investigating
We're seeing some elevated time to finalise messages over T-Mobile MMS routes.

We're working downstream to resolve this issue with T-Mobile.
Posted Oct 29, 2024 - 20:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.

Queue sizes are now depleting back to normal levels
Posted Oct 29, 2024 - 19:08 UTC
Update
We are currently investigating this issue.
Posted Oct 29, 2024 - 18:21 UTC
Investigating
We're seeing some elevated time to finalise messages over T-Mobile MMS routes.

We're working downstream to resolve this issue with T-Mobile.
Posted Oct 29, 2024 - 18:21 UTC
This incident affected: Programmable Messaging - Outbound (API V1, API V2) and Programmable Messaging - Long Codes (NORAM).