Wireless SIM Management Actions Delayed

Incident Report for Telnyx

Resolved

The delays in SIM card management actions have been resolved. All operations are processing normally.
Posted Mar 05, 2026 - 20:28 UTC

Investigating

We are investigating reports of delays in SIM card management actions. Actions such as SIM activation, suspension, and profile changes may take longer than expected.
Posted Mar 05, 2026 - 18:21 UTC
This incident affected: Programmable Wireless.