Possible Toll-Free delays towards U.S. Cellular end destinations.
Incident Report for Telnyx
Resolved
This incident has been resolved.
Posted May 26, 2023 - 07:13 UTC
Investigating
Issue identified of latency to U.S. Cellular end destinations.
Posted May 24, 2023 - 07:40 UTC