SMS latency Issues for Toll Free Numbers with T-Mobile

Incident Report for Telnyx

Resolved

The latency incident regarding T-Mobile has been resolved. SMS delivery to T-Mobile has returned to normal.
Posted Sep 29, 2023 - 19:50 UTC

Monitoring

We are observing an improvement in message latency toward T-Mobile. SMS delivery times return to normal. Further information will be promptly provided as available.
Posted Sep 29, 2023 - 17:41 UTC

Investigating

We are currently investigating potential SMS latency issues with T-Mobile. These issues may affect SMS delivery and receipts from/to T-Mobile for Toll Free Numbers. Further details to follow. Your patience is appreciated.
Posted Sep 29, 2023 - 16:51 UTC