[Monitoring] - Network Issues. Impacted: API, Voice, Messaging and Wireless services (Recurrence)
Incident Report for Telnyx
Resolved
Telnyx has observed all systems operational following an earlier DDoS incident. DDoS protection has been implemented across our network. All teams are continuing to actively monitor all services. Please continue to visit this status page in the event of further disruption.
Posted Nov 11, 2021 - 17:35 UTC
Update
We have concluded migration of global network traffic routes behind CloudFlare's DDoS protection systems. Migration began at 09:00 UTC and concluded at 09:48 UTC.

Customers may have experienced brief disruption to service during this period. At the time of correspondence, services are operational and teams are monitoring for signs of further disruption.

Please reach out to our support teams if you are experiencing further disruption.
Posted Nov 11, 2021 - 10:16 UTC
Update
EMEA and APAC routes have been successfully migrated to CloudFlare. Migration of peak traffic behind CloudFlare's protection systems has the potential to cause brief disruption to active traffic. We intend to complete migration of AMER routes during off-peak hours. We stand ready to migrate all remaining traffic immediately behind CloudFlare's protection services in the event of further attacks. Please continue to visit this status page for further updates.
Posted Nov 10, 2021 - 19:14 UTC
Update
We are continuing to monitor the situation closely. Please visit this status page for further updates.
Posted Nov 10, 2021 - 17:26 UTC
Update
We are working directly with CloudFlare to continue fortifying our DDoS mitigation systems. All teams are actively engaged in expediting this process.

At the time of writing, configuration is complete, and the teams are testing and validating our services behind CloudFlare’s DDoS protection.

We are monitoring the situation closely. Please continue to visit this status page for further updates.
Posted Nov 10, 2021 - 17:11 UTC
Update
Edge Configuration at Cloudflare is now complete. The testing of our EMEA and APAC ranges will begin momentarily. Please continue to visit this status page for further updates.
Posted Nov 10, 2021 - 12:37 UTC
Update
Telnyx has begun the process of migrating its transit to Cloudflare Magic Transit. Our team has established connectivity, set up routes, and is currently awaiting the propagation of our IP address space from Cloudflare's network. Telnyx expects that this process will happen progressively through the morning (UTC-6). Please continue to visit this status page for further updates.
Posted Nov 10, 2021 - 06:51 UTC
Update
Telnyx has observed partially restored services following an earlier incident. All teams are continuing to actively monitor all services. Please continue to visit this status page for further updates on individual services.
Posted Nov 10, 2021 - 02:21 UTC
Monitoring
Telnyx is continuing to experience a DDoS attack, which began earlier today. Until we reach a resolution, you may be experiencing failed calls, API and portal latency/time outs, and/or delayed or failed messages. All teams are actively engaged in resolving this issue.
Posted Nov 10, 2021 - 01:23 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 10, 2021 - 00:15 UTC
Identified
Telnyx is currently experiencing a second DDoS attack. Until we reach a resolution, you may be experiencing failed calls, API and portal latency/time outs, and/or delayed or failed messages.
Posted Nov 09, 2021 - 23:35 UTC
Update
We are continuing to investigate this issue.
Posted Nov 09, 2021 - 23:18 UTC
Update
Telnyx is currently experiencing a DDoS attack. Until we reach a resolution, you may be experiencing failed calls, API and portal latency/time outs, and/or delayed or failed messages.
Posted Nov 09, 2021 - 23:17 UTC
Investigating
We are currently investigating this issue. Services that may be impacted will be updated as soon as possible.
Posted Nov 09, 2021 - 23:04 UTC
This incident affected: LRN Lookup API (East Region, Central Region), Switch Data API (East Region, Central Region), CNAM API (Central Region, West Region), Numbering (Number Searching, Number Ordering), Telephony SIP Regions (US, Europe, Australia, Canada), TeXML (TeXML), Mission Control API (East Region, Central Region, West Region), and Messaging, Call Control, Wireless Core, Programmable Fax.