Google Signup broken
Incident Report for Telnyx
Resolved
This has been resolved, more details on what exactly triggered the the failure are being investigated.
Posted Jan 14, 2025 - 17:36 UTC
Investigating
We are currently investigating this issue.
Posted Jan 13, 2025 - 23:12 UTC