Website access failures and API failures due to issues with Cloudflare

Incident Report for Telnyx

Resolved

This incident has been resolved on Cloudflare's side as of 17:44UTC November 18th.
Posted Nov 19, 2025 - 15:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 18:56 UTC

Update

We are continuing to investigating this issue.

If you are continuing to experience issues to api.telnyx.com and api.telnyx.eu, please flush your DNS cache to resolve to our new functioning IP.
Posted Nov 18, 2025 - 13:47 UTC

Update

We are currently investigating this issue.
Posted Nov 18, 2025 - 12:14 UTC

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 11:56 UTC
This incident affected: Programmable Voice - Voice API (US, Europe), Mission Control Portal UI, Number Lookup API, and Mission Control API (US East Region, US Central Region, US West Region).