Wireless SIM Provisioning Delays

Incident Report for Telnyx

Monitoring

A fix has been implemented and we are monitoring the results. eSIM purchases and SIM card network registration should be recovering. We will continue to monitor and confirm full resolution.
Posted Mar 19, 2026 - 15:25 UTC

Investigating

We are currently investigating intermittent failures affecting eSIM purchases and SIM card network registration. Existing active SIM cards and data sessions are not affected — this issue only impacts new provisioning operations.

Our engineering team is actively investigating the root cause and working toward resolution. We will provide updates as more information becomes available.
Posted Mar 19, 2026 - 14:01 UTC
This incident affects: Programmable Wireless.