Possible MMS Delays to T-Mobile, issues receiving inbound MMS from T-Mobile
Incident Report for Telnyx
Resolved
This incident has been resolved.
Posted Oct 21, 2024 - 21:03 UTC
Update
We are noticing a decrease in the amount of inbound MMS from T-Mobile senders in addition to the delays seen in processing a subset of MMS messages outbound to T-Mobile. This delay in receiving inbound MMS from T-Mobile is present over long code routes only as well. Investigation is ongoing downstream. More updates to follow.
Posted Oct 17, 2024 - 19:11 UTC
Update
We have observed an issue in receiving acknowledgment delivery receipts, indicating a delay in processing a subset of MMS messages on the T-Mobile side. This delay is only present over long code routes only.

We have escalated this issue downstream for a resolution and will continue to monitor the situation closely. More updates to follow.
Posted Oct 17, 2024 - 18:17 UTC
Investigating
We are currently investigating potential delays with MMS sent to T-Mobile numbers. Updates will be provided as soon as they are available
Posted Oct 16, 2024 - 21:21 UTC
This incident affected: Programmable Messaging - Outbound (API V1, API V2) and Programmable Messaging - Long Codes (NORAM).