Scheduled API Gateway Maintenance - All regions

Scheduled for Feb 25, 11:00 - 13:00 UTC

Update

Enter scheduled maintenance deatils here.
Posted Feb 23, 2026 - 19:39 UTC

Update

Enter scheduled maintenance deatils here.
Posted Feb 23, 2026 - 19:38 UTC

Scheduled

Our Platform Engineers will perform maintenance on our API Gateway. This maintenance should not disrupt service.
Posted Feb 20, 2026 - 20:49 UTC
This scheduled maintenance affects: API Gateway.