Wireless Upgrades - Americas

Scheduled for Mar 31, 05:30 - 06:30 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 25, 2026 - 09:44 UTC

Scheduled

The Telnyx Wireless teams will perform upgrades to mobile data infrastructure in the North America region. This will cause a brief interruption (< 10 minutes) on 25% of existing data sessions on IMSI1 across North, Central and South America as well as the Caribbean.
Posted Mar 31, 2026 - 05:30 UTC
This scheduled maintenance affects: Programmable Wireless.