Increased 503s across APIs including Voice, Messaging, and Numbering

Incident Report for Telnyx

Resolved

This incident has been resolved.
Posted May 23, 2025 - 14:33 UTC

Update

We are continuing to monitor for any further issues.
Posted May 23, 2025 - 14:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 23, 2025 - 14:31 UTC

Investigating

We are currently investigating this issue.
Posted May 23, 2025 - 14:15 UTC
This incident affected: Programmable Voice - Voice API (US), Mission Control Portal UI, Porting, Mission Control API (US East Region, US Central Region, US West Region), and Programmable Messaging - Outbound (API V2).