Partial outage on payments (auto-recharge impacted as well)

Incident Report for Telnyx

Resolved

This incident has been resolved.
Posted Sep 19, 2024 - 12:15 UTC

Update

We continue to investigate this issue at this time, USD payements are now unaffected however non-USD payments using Visa and Mastercard may still fail.
Posted Sep 18, 2024 - 13:56 UTC

Update

Update: Visa and Mastercard payments made in USD currency are now going through successfully. Other currencies like AUD, CAD, EUR, GBP, etc. are not yet resolved and we continue to investigate.
Posted Sep 17, 2024 - 12:46 UTC

Investigating

Visa and MasterCard payments impacted.
Posted Sep 16, 2024 - 19:48 UTC
This incident affected: Mission Control Portal UI.