Possible Short Code message delays to US Cellular end destinations
Incident Report for Telnyx
Resolved
This incident has been resolved.
Posted May 23, 2023 - 21:10 UTC
Investigating
Issue identified of latency to US Cellular over short codes.
Posted May 23, 2023 - 20:00 UTC