Wireless SIM Management Actions Delayed

Incident Report for Telnyx

Resolved

The delays in SIM card management actions have been resolved. All operations are processing normally.
Posted Mar 16, 2026 - 22:46 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 16, 2026 - 21:40 UTC

Investigating

We are currently investigating this issue. Issue Started at roughly ~20:45 UTC
Posted Mar 16, 2026 - 20:10 UTC
This incident affected: Programmable Wireless.