Slack ticket creation issues

Incident Report for Telnyx

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:10 UTC

Investigating

We are currently experiencing issues with our slack ticket creation partner which may lead to intermittent failures and delays.

For support queries, we recommend opening tickets directly via email to support@telnyx.com.

They are investigating this issue, and we thank you for your patience.
Posted Oct 20, 2025 - 08:51 UTC
This incident affected: Mission Control Portal UI.