RCS Delivery Issues

Incident Report for Telnyx

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 02:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2026 - 02:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 06, 2026 - 01:16 UTC

Update

We are currently investigating an issue with delivery for a subset of RCS agents.

- Outbound messages are accepted downstream but are not being delivered.
- Inbound messages are also not reaching us.
Posted Mar 05, 2026 - 23:19 UTC

Investigating

We are currently investigating an issue with delivery for a subset of RCS agents. Messages are accepted downstream but are not being delivered.

Inbound remains unaffected.
Posted Mar 05, 2026 - 22:55 UTC
This incident affected: Programmable Messaging - Outbound (API V2).