API degradation

Incident Report for Telnyx

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 14:06 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2025 - 12:53 UTC

Investigating

Elevated level of 503 API responses
Posted Jun 26, 2025 - 12:34 UTC
This incident affected: Programmable Voice - Voice API (US, Europe), SIP Trunking - Signaling Regions (US, Europe, Canada), SIP Trunking - Media Anchorsites (Chicago, IL, San Jose, CA, London, UK, Sydney, Australia, Frankfurt, Germany, Toronto, Canada), Programmable Voice - TeXML (US, Europe), and Mission Control Portal UI, Programmable Wireless, Programmable Video, Telnyx Storage, Porting, Number Lookup API.