Order activation delays in select EU countries

Incident Report for Telnyx

Resolved

This incident has been resolved.
Posted May 22, 2026 - 21:16 UTC

Monitoring

Our downstream vendor is experiencing an outage. This outage blocks pending number orders from completing.

This impacts number orders in the following countries: Italy, Switzerland, Norway, Sweden, Denmark, and Portugal.

In those countries only, we will refrain from activating number orders until the outage is resolved.
Posted May 22, 2026 - 15:05 UTC
This incident affected: Numbering (Number Searching, Number Ordering).