Issues displaying 10DLC brands on the portal

Incident Report for Telnyx

Resolved

This incident has been resolved.
Posted Aug 22, 2025 - 09:22 UTC

Investigating

The Campaign Registry is currently experiencing issues which is resulting in brands not displaying correctly on the Mission Control portal.

They are investigating this issue, please note that the brands are still active and have not been removed.
Posted Aug 21, 2025 - 15:31 UTC
This incident affected: Mission Control Portal UI.