Issues with live chat functionality on Mission Control Portal

Incident Report for Telnyx

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:10 UTC

Investigating

Our live chat service provider is currently experiencing issues at this time, leading to increased agent response times over portal chat.

In the mean-time, please submit queries via email to support@telnyx.com for assistance.

They are investigating this issue, and we thank you for your patience.
Posted Oct 20, 2025 - 08:15 UTC
This incident affected: Mission Control Portal UI.