Need help with an issue not listed here? Please contact Telnyx Support via https://telnyx.com/contact-us. For more information, see our Privacy Policy and Terms of Service linked below.
We identified a capacity issue in the backend service that manages telephony tokens and client SDK credentials. This caused intermittent failures for some credential-related API requests.
We increased the number of service pods and raised CPU and memory allocation to better handle request volume. Since making these changes, we are no longer seeing the related 503 errors at the API gateway.
The service is currently stable, and we will continue monitoring closely while the incident remains in the monitoring phase.
Monitoring
We identified a capacity issue in the backend service that manages telephony tokens and client SDK credentials. This caused intermittent failures for some credential-related API requests.
We increased the number of service pods and raised CPU and memory allocation to better handle request volume. Since making these changes, we are no longer seeing the related 503 errors at the API gateway.
The service is currently stable, and we will continue monitoring closely while the incident remains in the monitoring phase.
Investigating
customers may receive HTTP 503 responses from the Client Credential API, which can prevent telephony token creation or validation. This may cause Voice SDK authentication failures, failed registrations, and new call setup failures. Existing active calls are likely unaffected unless they require a fresh token/API call.