Need help with an issue not listed here? Please contact Telnyx Support via https://telnyx.com/contact-us. For more information, see our Privacy Policy and Terms of Service linked below.
Resolved
The issue affecting MMS delivery reports to T-Mobile has been resolved.
MMS delivery reports are now processing as expected.
Investigating
We are currently investigating an issue affecting MMS message delivery to T-Mobile, where some messages are resulting in a delivery_unconfirmed status.
The issue has been escalated to our downstream partner for further investigation, and we are currently awaiting additional updates. We will provide more information as it becomes available.