Need help with an issue not listed here? Please contact Telnyx Support via https://telnyx.com/contact-us. For more information, see our Privacy Policy and Terms of Service linked below.
Resolved
Services were restored on June 11th, 2026 at 18:25 UTC
Identified
New Data Sessions on IMSI2 impacted
Investigating
We have identified a subset of IMSI2 users are currently failing to achieve a stable data session. No other connectivity is affected.