Need help with an issue not listed here? Please contact Telnyx Support via https://telnyx.com/contact-us. For more information, see our Privacy Policy and Terms of Service linked below.
Identified
eSIM stock has been replenished. eSIM purchases are now working.
Identified
New eSIM purchases currently failing due to depleted stock. New batches of eSIMs are being provisioned to address this
Investigating
We are unable to fulfill eSIM purchase requests. We are actively debugging the issue.