Need help with an issue not listed here? Please contact Telnyx Support via https://telnyx.com/contact-us. For more information, see our Privacy Policy and Terms of Service linked below.
Resolved
The delays in SIM card management actions have been resolved. All operations are processing normally.
Investigating
We are investigating reports of delays in SIM card management actions. Actions such as SIM activation, suspension, and profile changes may take longer than expected.