Need help with an issue not listed here? Please contact Telnyx Support via https://telnyx.com/contact-us. For more information, see our Privacy Policy and Terms of Service linked below.
No components marked as affected
Resolved
This incident was resolved as of 18:00 PM UTC 15th July 2021.
Monitoring
Telnyx has recently received confirmation, as of 18:00 PM UTC, that the multi-part issue causing messages to be delivered out of order has been resolved. We continue to monitor the situation to ensure this incident has been fully mitigated.
Investigating
Both T-Mobile and Verizon have recently conducted emergency maintenance (15th July 2021 06:00 - 10:00 AM UTC) and during this window, customers may have experienced potential delays delivering messages from and to Verizon, T-Mobile and subsidiary subscriber devices via short-code, long-code and toll-free.
Telnyx has received reports from customers that outbound messages towards these carriers are being delivered in the incorrect order or where one part messages are being split up into multi-part messages.
Telnyx is working with all parties involved to ensure the issues observed are resolved.