Need help with an issue not listed here? Please contact Telnyx Support via https://telnyx.com/contact-us. For more information, see our Privacy Policy and Terms of Service linked below.
Resolved
This incident has been resolved.
Investigating
We continue to investigate this issue at this time, USD payements are now unaffected however non-USD payments using Visa and Mastercard may still fail.
Investigating
Update: Visa and Mastercard payments made in USD currency are now going through successfully. Other currencies like AUD, CAD, EUR, GBP, etc. are not yet resolved and we continue to investigate.
Investigating
Visa and MasterCard payments impacted.