Partial failures with requests to call control & TeXML based endpoints
Incident Report for Telnyx
Resolved
This incident has been resolved.
Posted May 20, 2020 - 19:22 UTC
Update
We are continuing to monitor the call control / texml services and have continued to see improvements since the initial fixes that were implemented at 16:30 PM UTC.
Posted May 20, 2020 - 18:46 UTC
Update
We are continuing to monitor the call control / texml services and have continued to see improvements since the initial fixes that were implemented at 16:30 PM UTC.
Posted May 20, 2020 - 17:42 UTC
Monitoring
We have been informed that our engineers have implemented several fixes and that there has been a decrease in 5XX responses, since 16:00 PM UTC. They still have a few remaining action items, which are currently in progress. Further updates to be provided in the next hour.
Posted May 20, 2020 - 16:43 UTC
Update
Our engineers continue to work on resolving the issue.
Posted May 20, 2020 - 15:32 UTC
Identified
The issue has been identified and the engineers are working on a fix.
Posted May 20, 2020 - 14:53 UTC
Investigating
We have identified partial failures with requests to call control & TeXML based endpoints that started occurring at 13:00 PM UTC and at 14:00 PM UTC.

Users may have seen a 5XX response from our API proxies when attempting to initiate new control & TeXML requests. Calls that were already in progress, where new commands were issued, may have failed to have been processed during this time-frame.

Our engineers continue to investigate in order to mitigate the issue fully.
Posted May 20, 2020 - 14:21 UTC
This incident affected: Programmable Voice - Voice API (US).