Mission Control Portal: Delay in changes to account settings
Incident Report for Telnyx
Resolved
This incident has been confirmed fully resolved as delays are no longer observed.
Posted Jan 06, 2021 - 16:37 UTC
Monitoring
Since 15:50 PM UTC, the backlog of events have been clearing. Customers should start to see better behaviour where call recordings are being delivered in a more timely fashion along with other resources being usable since their creation. The recommendation is to again still re-apply the changes previously made to any resources on your account ensure they are configured correctly. Engineers are continuing to monitor at this time.
Posted Jan 06, 2021 - 16:10 UTC
Update
Our engineers continue to work on a mitigation solution for the delayed events, some adjustments have been made already and improvements can be seen as the delays are decreasing.
Posted Jan 06, 2021 - 16:02 UTC
Identified
Other observations include delays in JWTs and their associated WebRTC calls for newly created SIP Connections as well as call recordings being delayed after a call ends.

Our engineers have identified the cause of the delay and are working on a resolution.
Posted Jan 06, 2021 - 15:34 UTC
Investigating
At 14:51 PM UTC, any changes customers make on the mission control portal, such as editing SIP Connections or other similar resources, may result in a delay taking effect. Our engineers are investigating the root cause of the delay at this time. The recommendation is to disable/re-enable/assign/unassign the changes again as a workaround.
Posted Jan 06, 2021 - 15:18 UTC
This incident affected: Mission Control API (East Region, Central Region, West Region).