Inbound Toll Free failures
Incident Report for Telnyx
Resolved
We have continued to monitor and confirm we have had no new reported incidents with regards to inbound call failures to Telnyx Toll Free DID's since 03:05:30 PM US CENTRAL, when Verizon was removed.

At this point the relevant teams are still engaging on finding a solution to the intermittent nature of receiving calls with Verizon.

Until such a time, Verizon will continue to stay removed from route and we assure our customers that we've a plan in place to minimize and resolve any such potential future occurrences.

We sincerely apologize for any inconvenience caused and thank our customers for their continued patience.

Telnyx NOC, 24x7.
Posted Jul 03, 2018 - 22:47 UTC
Monitoring
Inbound calls to Toll Free DID's have been reaching our network since 03:05:30 PM US CENTRAL.

We continue to monitor the situation while our engineers are engaging in finding a resolution with Verizon.
Posted Jul 03, 2018 - 20:58 UTC
Identified
We identified that Verizon has been having intermittent issues originating calls into Telnyx Toll Free DID's.

We have completely removed them from route but any other customers that rely on Verizon for originating calls into their Toll Free DID's will still see intermittent issues until Verizon resolve the issue.

Our engineers are still engaging with Verizon at this point and we will continue to provide updates.

We thank you for your continued patience.
Posted Jul 03, 2018 - 20:20 UTC
Update
Inbound calls to Telnyx Toll Free's were restored during Jul 3, 2018 02:19:17 PM to Jul 3, 2018 02:28:45 PM US CENTRAL.

From this point on, inbound calls began to fail again and we are still investigating to see why calls are failing to reach us.
Posted Jul 03, 2018 - 19:52 UTC
Investigating
We are investigating an issue where inbound calls to Telnyx Toll Free's are not reaching our switch.

The issue started at Jul 3, 2018 01:36:01 PM US CENTRAL and has been intermittent since.

We are continuing to investigate upstream from Telnyx with multiple carriers to determine why calls are failing route.
Posted Jul 03, 2018 - 19:41 UTC