Billing Issues
Incident Report for Telnyx
Resolved
We have confirmed that the issue is now resolved.

As always, if this is an emergency, please visit our website at www.telnyx.com for a live chat or call our support line at 888.980.9750. We are here 24x7 to assist you with any issues that you might have.
Posted Oct 04, 2019 - 17:04 UTC
Monitoring
We have identified issues with our billing service where calls were listed as being active for long periods of time when they were in fact not.

We have since fixed the issue and will continue to monitor.
Posted Oct 04, 2019 - 14:48 UTC